iPad sync fail 2

Cal's Avatar

Cal

19 Jan, 2015 08:33 PM

Hi Sam

Thank you for your response. I have had Mentalcase open almost all weekend and it still resolutely says 'Cloud data is fully downloaded' yet has zero cards in the library. Mac and iPhone are still absolutely fine, show all of my 4000+ cards, and update after a study session. I would far prefer to study on my iPad and would like to get this issue resolved...

Cheers
Cal

  1. Support Staff 1 Posted by support on 20 Jan, 2015 05:26 AM

    support's Avatar

    Hi Cal,

    I'm sorry to hear about this continued issue. It sounds like something got messed up with the sync. Can you try resetting the sync data on all your devices, like this

    1) Press the Reset button in the iCloud settings of Mental Case on each device
    2) Wait 30 minutes
    3) Press Reset on all devices again
    4) Turn on sync on device at a time, waiting 10 minutes between each

    Best,

    Sam R. — The Mental Faculty support

  2. support closed this discussion on 20 Jan, 2015 05:26 AM.

  3. calhawes re-opened this discussion on 21 Jan, 2015 03:43 PM

  4. 2 Posted by calhawes on 21 Jan, 2015 03:43 PM

    calhawes's Avatar

    Hi Sam

    I’ve followed your instructions to the letter, including using a stopwatch to ensure that I didn’t take any one step earlier than required! It has made no difference to the iPad - which is very frustrating.

    In a new development, my iPhone gave up the ghost yesterday morning so I have replaced it with a new one. I’ve tried to set up the new phone with Mental Case and am experiencing exactly the same problems with the new iPhone as I am with the iPad, ie it says that it downloads, completes the download, then shows no cards in the library.

    <sigh> Can I have my old Mentalcase system back? It worked a treat and was never any problem

    Cal

  5. Support Staff 3 Posted by support on 22 Jan, 2015 02:08 PM

    support's Avatar

    Hi Cal,

    Thank you for writing in. I'm very sorry to hear about this issue. We're continually working on improving iCloud sync. Please note it's important that your devices are all on iCloud drive (Yosemite, iOS 8.1) or none or your devices are, a mix between the two isn't possible.

    I would also like to recommend checking out this article in our knowledge base. It has a lot of information regarding iCloud sync. Sometimes the only thing to try is to start over with iCloud sync, described from step 8 on.

    We added Dropbox sync as an option just recently, so if you can't get iCloud to work please give Dropbox a shot.

    We apologise for any frustration we have caused. Please don't hesitate to contact us with any other questions you might have, we're here to help.

    Best,

    Sam R. — The Mental Faculty support

  6. support closed this discussion on 22 Jan, 2015 02:08 PM.

  7. calhawes re-opened this discussion on 22 Jan, 2015 08:34 PM

  8. 4 Posted by calhawes on 22 Jan, 2015 08:34 PM

    calhawes's Avatar

    Hi Sam, thanks for the link. I tried switching to Dropbox in an earlier attempt to fix the problem but it made no difference to iPad, and I know that my flashcard data uploaded successfully. I think I'll try starting over with iCloud. Fingers crossed!

    Cal

  9. 5 Posted by zeppo on 23 Jan, 2015 12:04 AM

    zeppo's Avatar

    Just a suggestion, having had sync issues myself. Make sure you are logged into iCloud on the iPad. Also, if you are logged in, try logging off of iCloud and logging back in again on each device. I was logged in on both devices that I was trying to sync, but one of the things I did before I finally got it to work (after performing a sync reset per Sam and Drew's instructions for a second time, was to log out of iCloud and then back in again on both my iMac and iPhone. My guess is Drew would say this isn't necessary, but I figured it couldn't hurt and the first attempt to reset things didn't work, so what did I have to lose.

     I would create a backup of your phone to iTunes before trying to start over with iCloud, just in case something gets fouled up.

  10. support closed this discussion on 23 Jan, 2015 06:08 AM.

  11. calhawes re-opened this discussion on 26 Jan, 2015 08:37 PM

  12. 6 Posted by calhawes on 26 Jan, 2015 08:37 PM

    calhawes's Avatar

    I’m coming to the conclusion that it’s a Cloud Drive issue and not Mentalcase at all. I have begun to notice other apps having trouble syncing across devices.

    Out of the blue, the iPad suddenly decided it has cards in storage after all and is now showing the same number as the Mac. It still won’t respond to changes to the Mac though, like when I study some cards… Still, small victories.

    Cal

  13. support closed this discussion on 27 Jan, 2015 08:11 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac