Sync hangs

Sergey's Avatar

Sergey

25 Jan, 2011 02:36 AM

Hi.
I just tried several times to sync my notes to iPhone, but every time sync starts, but then just kind of hangs - the progress bar not moving. I decided to purchase version for iPad, then tried to sync, but I got the same thing.
I use computer-to-computer network.

Sergey.

  1. Support Staff 1 Posted by drewmccormack on 25 Jan, 2011 07:12 AM

    drewmccormack's Avatar

    Hi Sergey,
    If you are syncing a lot of data, it can seem as though the sync is hanging, particularly when it is copying a bunch of photos and the bar moves very slowly.
    You should wait to be sure it really has stalled.
    If it really is stalling, I suggest trying to sync fewer cards by selecting just the cases you need.
    Note also that all lesson notes are synced over, so if you don't use the lesson, go into preferences in the Mac app and set the learning schedule to None.
    Kind regards,
    Drew

  2. 2 Posted by Sergey on 25 Jan, 2011 12:29 PM

    Sergey's Avatar

    Hi Drew.
    I tried to sync one case with 20 cards. I left it syncing for 20 minutes, but it did not sync. Any tips what I should do?

    Sergey.

  3. Support Staff 3 Posted by drewmccormack on 25 Jan, 2011 12:38 PM

    drewmccormack's Avatar

    Can you describe what you saw? Did the Mac see the iPhone?
    Note that syncing is via WiFi, not via iTunes or USB.
    More info is at

    http://mentalfaculty.tenderapp.com/faqs

    Kind regards,
    Drew

  4. 4 Posted by Sergey on 25 Jan, 2011 01:34 PM

    Sergey's Avatar

    O, I understand that syncing is via WiFi. I created computer-to-computer network. Both, iPhone and iPad saw that network. MentalCase Desktop App saw either iPhone or iPad; I only tried one device at a time. I clicked connect button, chose one lesson with 20 cards, and clicked sync. It started syncing... ,and after 20 minutes it didn't finish with progress bar showing about 40 %.

  5. Support Staff 5 Posted by drewmccormack on 25 Jan, 2011 01:36 PM

    drewmccormack's Avatar

    Is there a lot of notes in your Lesson on the Mac? These also get synced, no matter what you choose.
    If you don't use the lesson, you can turn it off in the Preferences on the Mac.
    Sometimes syncs seem to stall, but they are just copying across images. If you wait, it does finish.

    Kind regards,
    Drew

  6. 6 Posted by Sergey on 25 Jan, 2011 01:41 PM

    Sergey's Avatar

    I turned it off . See the screenshot. It has 0 notes in lesson.

    Thanks,
    Sergey.

  7. Support Staff 7 Posted by drewmccormack on 25 Jan, 2011 01:46 PM

    drewmccormack's Avatar

    It is difficult to say what is going wrong. It can be a network issue, but a computer-to-computer network usually works.
    It could also be some corrupt data.
    Did you try syncing any other cases? Why not try making a case with just one or two text-only notes, and see if that works. It should only take a couple of seconds.
    If that works, you can try something a bit bigger. Try to isolate what is causing the problem.
    Also, it might be worth looking in the Console utility in Applications/Utilities to see if any messages are printed when the sync stalls.

    Kind regards,
    Drew

  8. 8 Posted by Sergey on 25 Jan, 2011 01:48 PM

    Sergey's Avatar

    OK. I am not in front of my Mac right now. I will try tonight.
    Thanks.
    Sergey.

  9. 9 Posted by Sergey on 26 Jan, 2011 12:30 AM

    Sergey's Avatar

    I created a new case with one note, and it synced successfully.
    However, when I tried an old case with 20 notes it stalled.
    Here is the message I got for MentalCase in Console:
    1/25/11 19:18:51 Mental Case[277] CoreData could not fulfill a fault for '0x544f30 <x-coredata://E151EBD1-6AAE-43C3-893D-79D13FB66627/Media/p514>'

    Also a little background information. I've had MentalCase, but I purchased it again from app store again, so I can get free upgrade to version 2.0 as you advertised. May be this upgrade could screw things up?
    I am thinking to export the cases that matters for me, then delete all MentalCase data from Library/Application Support/MentalCase/.
    What do you think?

    Thanks,
    Sergey.

  10. Support Staff 10 Posted by drewmccormack on 26 Jan, 2011 08:43 AM

    drewmccormack's Avatar

    The upgrade should not have caused the issue. We didn't change the data at all.
    The message points to some data corruption. It is probably in the case you tried to export. You could try selecting notes in that case and exporting those until one fails. Then you should know which note is corrupted, and you can delete it.
    If that doesn't help, you could indeed export important data, move aside the library file (don't delete it though), and start afresh.

    Drew

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_shot_2011-01-24_at_21.34.05_.png 353 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac