Mac OS too recent

Indi's Avatar

Indi

12 Jan, 2013 10:16 AM

I'm very upset that the mac software requires OS 10.7. My MacAir is only 3 years old, yet it is already dated for a flashcarfd app?? I don't see the need in buying expensive OS upgrades, espacially considering most people looking into flashcard apps are students (like myself) and can't afford that luxury. Please let me know if there are any alternatives, as I would really like to purchase just the mac software, and not the whole shebang. Thanks

  1. 1 Posted by support on 13 Jan, 2013 08:22 AM

    support's Avatar

    Hi There,

    Thank you for contacting us! Unfortunately Mental Case is only available on the Mac App Store and we don't have a way to provide older versions. We are sorry for any inconvenience.

    Thank you for choosing The Mental Faculty!

    Sincerely,
    Jason W. -- The Mental Faculty Support

  2. support closed this discussion on 13 Jan, 2013 08:22 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac